To add a bit of detail, there are AP images that have an image file size limit. If these units are upgraded to a newer version with a larger image, one should see this error message in the log:
Nov 15 08:02:04 2023 sapd[2205]: <311014> <ERRS> |AP 80:8d:b7:ce:de:96@136.230.36.56 sapd| ERROR: File size exceeded 14680064 bytes
The alternative to the process outlined is to upgrade the second (recovery) partition to a more modern version that can handle the larger image files. (partition 1 is used during AOS upgrades), which does not require AP console access.
If the AP is connected to an Aruba controller, "show ap image version" will show the active image, and the contents of both partitions.
a) if the unit is UAP, convert or factory default (which uses the 2nd partition) and perform an IAP upgrade twice - the 1st will overwrite partition 0, the 2nd will overwrite
partition 1
b) Attach the AP to an Aruba controller with an older version, and forcibly upgrade the 2nd partition to a more modern version, but still small enough for the
AP to accept. When this newer more modern version is installed, we can then upgrade to newer versions which have larger images.
The ASP site notifications offer this bulletin which provides more detail:
ARUBA-SA-20220922-PLVL02 :: Older AP-320 Series Access Points ArubaOS Upgrade and AP Firmware File Size Limitation (Rev-1)
Sep 23, 2022
If these AP-315s can be connected as Campus APs, first upgrade to one of the following ArubaOS versions:
ArubaOS 6.5.4.23 or higher
ArubaOS 8.6.0.17 or higher
ArubaOS 8.7.1.9 or higher
ArubaOS 8.9.0.3 or higher
ArubaOS 8.10.0.0 or higher
------------------------------
Shawn Adams
------------------------------
Original Message:
Sent: Dec 07, 2023 05:12 AM
From: mkk
Subject: AP-315 image upgrade failed (AOS6 to 8)
Hi,
I had exact the same issue. Customer runs AOS8.10.07 and had a bunch AP-315 with 6.x code the lay down in the warehouse for a couple of years.
Solved it removing the backup partition from the CLI, becasuse the Aruba solutions didnt work for me).
apboot> clear cache
Erasing flash sector @ 0x3a0000...OK
Device 0: nand0... is now current device
Erasing UBIFS ...OK
Remove UBI volume ubifs (id 0)
Creating dynamic volume ubifs of size 63234048
Device 1: nand1... is now current device
apboot> clear os 1
512 bytes written to volume aos1
apboot> safe
Unknown command 'safe' - try 'help'
apboot> s
saveenv setenv
apboot> saveenv
Saving Environment to Flash...
Erasing flash...
Writing to flash... ...............done
apboot> boot
------------------------------
Marcel Koedijk | MVP Expert 2023 | ACEP | ACMP | ACCP | ACDP | Ekahau ECSE | Not an HPE Employee | Opinions are my own
------------------------------