Network Management

 View Only
  • 1.  IMC 7.3 - Upgrade error

    Posted Feb 01, 2017 07:26 AM

    Hi everyone,

    I tried to perform the upgrade to the version 7.3 of IMC but I got the error below :

    Batch upgrade interrupted. Please retry it.

    And the result in the log file when I click ok :

    2017-02-01 13:19:17 [INFO ] [main] [com.h3c.imc.deploy.DMALauncher::a(1063)] Binding server port error, DMA already started.
    2017-02-01 13:19:22 [INFO ] [main] [com.h3c.imc.deploy.DMALauncher::f(1262)] "SHUTDOWN" command is sent.
    2017-02-01 13:19:23 [INFO ] [Thread-4] [com.h3c.imc.deploy.dma.a::run(885)] Agent start connect to server
    2017-02-01 13:19:24 [INFO ] [ActiveMQ Task-1] [com.h3c.imc.deploy.dma.c::transportResumed(899)] Agent transport resumed
    2017-02-01 13:19:24 [INFO ] [ActiveMQ Task-1] [com.h3c.imc.deploy.dma.AgentMessageHandler::a(1053)] Agent-Server connect state changed: Connected
    2017-02-01 13:19:24 [INFO ] [ActiveMQ Task-1] [org.apache.activemq.transport.failover.FailoverTransport::doReconnect(1040)] Successfully connected to tcp://localhost:61626
    2017-02-01 13:19:24 [INFO ] [Thread-4] [com.h3c.imc.deploy.dma.a::run(921)] Agent connection started
    2017-02-01 13:19:24 [INFO ] [Thread-4] [com.h3c.imc.deploy.dma.AgentMessageHandler::a(1053)] Agent-Server connect state changed: Connected
    2017-02-01 13:19:24 [INFO ] [Thread-4] [com.h3c.imc.deploy.dma.a::run(944)] Create Agent MQ connection completed
    2017-02-01 13:19:24 [INFO ] [iMC-Database-Connect-Check] [com.h3c.imc.deploy.dma.IPConfigFileManager::a(168)] Start loading server-addr.xml configuration file
    2017-02-01 13:19:24 [INFO ] [iMC-Database-Connect-Check] [com.h3c.imc.deploy.dma.IPConfigFileManager::a(232)] Load server-addr.xml configuration file succeeded
    2017-02-01 13:19:25 [INFO ] [AWT-EventQueue-0] [com.h3c.imc.deploy.dma.DBManConfiguration::setAgentMessageHandler(300)] this server is Master:true
    2017-02-01 13:19:25 [INFO ] [Thread-14] [com.h3c.imc.deploy.dma.IPConfigFileManager::a(168)] Start loading server-addr.xml configuration file
    2017-02-01 13:19:25 [INFO ] [Thread-14] [com.h3c.imc.deploy.dma.IPConfigFileManager::a(232)] Load server-addr.xml configuration file succeeded
    2017-02-01 13:19:25 [INFO ] [ActiveMQ Session Task-1] [com.h3c.imc.deploy.dma.AgentMessageHandler::a(1078)] Receive master state change message: Connected
    2017-02-01 13:19:25 [INFO ] [AWT-EventQueue-0] [com.h3c.imc.deploy.dma.ComponentDeployInfo::isComponentsConformable(493)] Components conformable check failed: cdInfo is empty
    2017-02-01 13:19:25 [INFO ] [AWT-EventQueue-0] [com.h3c.imc.deploy.dma.ComponentDeployInfo::isComponentsConformable(493)] Components conformable check failed: cdInfo is empty
    2017-02-01 13:19:25 [INFO ] [AWT-EventQueue-0] [com.h3c.imc.deploy.dma.ComponentDeployInfo::isComponentsConformable(493)] Components conformable check failed: cdInfo is empty
    2017-02-01 13:19:25 [INFO ] [main] [com.h3c.imc.deploy.dma.DeployManager::a(791)] Component deploy state changed
    2017-02-01 13:19:27 [INFO ] [SwingWorker-pool-2-thread-1] [com.h3c.imc.deploy.dma.IPConfigFileManager::a(168)] Start loading server-addr.xml configuration file
    2017-02-01 13:19:27 [INFO ] [SwingWorker-pool-2-thread-1] [com.h3c.imc.deploy.dma.IPConfigFileManager::a(232)] Load server-addr.xml configuration file succeeded
    2017-02-01 13:19:29 [INFO ] [SwingWorker-pool-2-thread-2] [com.h3c.imc.deploy.install.InstallationComponentInfo::b(596)] Can not find java-monitor configurations in deploy configs, but found in update configs
    2017-02-01 13:19:29 [INFO ] [SwingWorker-pool-2-thread-2] [com.h3c.imc.deploy.install.InstallationComponentInfo::b(596)] Can not find java-monitor configurations in deploy configs, but found in update configs
    2017-02-01 13:19:29 [INFO ] [SwingWorker-pool-2-thread-2] [com.h3c.imc.deploy.install.InstallationComponentInfo::b(596)] Can not find java-monitor configurations in deploy configs, but found in update configs
    2017-02-01 13:19:29 [INFO ] [SwingWorker-pool-2-thread-2] [com.h3c.imc.deploy.install.InstallationComponentInfo::b(596)] Can not find java-monitor configurations in deploy configs, but found in update configs
    2017-02-01 13:20:58 [INFO ] [AWT-EventQueue-0] [com.h3c.imc.deploy.dma.ComponentDeployInfo::isComponentsConformable(506)] Components conformable check failed: invalid state - updating
    2017-02-01 13:21:14 [INFO ] [SwingWorker-pool-2-thread-2] [com.h3c.imc.deploy.dma.SlaveUpdateWorker::doWork(146)] Start update component: iMC-PLAT [iMC PLAT 7.3 (E0504)]
    2017-02-01 13:21:14 [INFO ] [SwingWorker-pool-2-thread-2] [com.h3c.imc.deploy.dma.SlaveUpdateWorker::doWork(158)] Replacement Variables: {${COUNTRY}=US, ${DATABASE_ADDRESS}=127.0.0.1, ${DATABASE_ADMIN_PASSWORD}={PROTECTED}, ${DATABASE_ADMIN_USERNAME}=sa, ${DATABASE_PORT}=1433, ${DATABASE_TYPE}=SQLServer, ${DATAFILE_DIR}=C:\Program Files\imcdata, ${DEPLOY_IP}=127.0.0.1, ${INSTALL_DESTINATION_DIR}=C:\Program Files\iMC, ${INSTANCE_NAME}=, ${LANGUAGE_U}=C, ${LANGUAGE}=en, ${LOCAL_IP_0}=172.30.20.101, ${LOCAL_IP_1}=fe80:0:0:0:8192:476d:1e4:6e27%12, ${LOCAL_IP_2}=fe80:0:0:0:0:5efe:ac1e:1465%13, ${LOCAL_IP_COUNT}=3, ${MASTER_IP}=localhost, ${SERVER_TYPE}=Master, ${SQLSERVER_COLLATE_CS}=, ${SQLSERVER_COLLATE}=, ${iMC-ACLM['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-ACLM['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-ACLM['DATABASE_NAME']}=aclm_db, ${iMC-ACLM['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-ACLM['DATABASE_PORT']}=1433, ${iMC-ACLM['DATABASE_TYPE']}=SQLServer, ${iMC-ACLM['DATABASE_USER_NAME']}=imc_aclm, ${iMC-ACLM['DEPLOY_IP']}=127.0.0.1, ${iMC-ACLM['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-ACLM['INSTANCE_NAME']}=null, ${iMC-ACLM['JDBC_INSTANCE_NAME']}=, ${iMC-ACLM['SERVER_TYPE']}=Master, ${iMC-ACLM['VERSION']}=7.2-E0403P10, ${iMC-DM['DEPLOY_IP']}=127.0.0.1, ${iMC-DM['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-DM['VERSION']}=7.2-E0403P10, ${iMC-EUPLAT['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-EUPLAT['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-EUPLAT['DATABASE_NAME']}=config_db, ${iMC-EUPLAT['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-EUPLAT['DATABASE_PORT']}=1433, ${iMC-EUPLAT['DATABASE_TYPE']}=SQLServer, ${iMC-EUPLAT['DATABASE_USER_NAME']}=imc_config, ${iMC-EUPLAT['DEPLOY_IP']}=127.0.0.1, ${iMC-EUPLAT['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-EUPLAT['INSTANCE_NAME']}=null, ${iMC-EUPLAT['JDBC_INSTANCE_NAME']}=, ${iMC-EUPLAT['VERSION']}=7.2-E0403P10, ${iMC-GAM['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-GAM['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-GAM['DATABASE_NAME']}=config_db, ${iMC-GAM['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-GAM['DATABASE_PORT']}=1433, ${iMC-GAM['DATABASE_TYPE']}=SQLServer, ${iMC-GAM['DATABASE_USER_NAME']}=imc_config, ${iMC-GAM['DEPLOY_IP']}=127.0.0.1, ${iMC-GAM['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-GAM['INSTANCE_NAME']}=null, ${iMC-GAM['JDBC_INSTANCE_NAME']}=, ${iMC-GAM['VERSION']}=7.2-E0403P10, ${iMC-ICC['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-ICC['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-ICC['DATABASE_NAME']}=icc_db, ${iMC-ICC['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-ICC['DATABASE_PORT']}=1433, ${iMC-ICC['DATABASE_TYPE']}=SQLServer, ${iMC-ICC['DATABASE_USER_NAME']}=imc_icc, ${iMC-ICC['DEPLOY_IP']}=127.0.0.1, ${iMC-ICC['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-ICC['INSTANCE_NAME']}=null, ${iMC-ICC['JDBC_INSTANCE_NAME']}=, ${iMC-ICC['SERVER_TYPE']}=Master, ${iMC-ICC['VERSION']}=7.2-E0403P10, ${iMC-NETASSET['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-NETASSET['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-NETASSET['DATABASE_NAME']}=invent_db, ${iMC-NETASSET['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-NETASSET['DATABASE_PORT']}=1433, ${iMC-NETASSET['DATABASE_TYPE']}=SQLServer, ${iMC-NETASSET['DATABASE_USER_NAME']}=imc_inventory, ${iMC-NETASSET['DEPLOY_IP']}=127.0.0.1, ${iMC-NETASSET['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-NETASSET['INSTANCE_NAME']}=null, ${iMC-NETASSET['JDBC_INSTANCE_NAME']}=, ${iMC-NETASSET['SERVER_TYPE']}=Master, ${iMC-NETASSET['VERSION']}=7.2-E0403P10, ${iMC-NME-FAULT['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-NME-FAULT['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-NME-FAULT['DATABASE_NAME']}=monitor_db, ${iMC-NME-FAULT['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-NME-FAULT['DATABASE_PORT']}=1433, ${iMC-NME-FAULT['DATABASE_TYPE']}=SQLServer, ${iMC-NME-FAULT['DATABASE_USER_NAME']}=imc_monitor, ${iMC-NME-FAULT['DEPLOY_IP']}=127.0.0.1, ${iMC-NME-FAULT['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-NME-FAULT['INSTANCE_NAME']}=null, ${iMC-NME-FAULT['JDBC_INSTANCE_NAME']}=, ${iMC-NME-FAULT['SERVER_TYPE']}=Master, ${iMC-NME-FAULT['VERSION']}=7.2-E0403P10, ${iMC-NME-PERF['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-NME-PERF['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-NME-PERF['DATABASE_NAME']}=perf_db, ${iMC-NME-PERF['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-NME-PERF['DATABASE_PORT']}=1433, ${iMC-NME-PERF['DATABASE_TYPE']}=SQLServer, ${iMC-NME-PERF['DATABASE_USER_NAME']}=imc_perf, ${iMC-NME-PERF['DEPLOY_IP']}=127.0.0.1, ${iMC-NME-PERF['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-NME-PERF['INSTANCE_NAME']}=null, ${iMC-NME-PERF['JDBC_INSTANCE_NAME']}=, ${iMC-NME-PERF['SERVER_TYPE']}=Master, ${iMC-NME-PERF['VERSION']}=7.2-E0403P10, ${iMC-PLAT['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-PLAT['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-PLAT['DATABASE_NAME']}=config_db, ${iMC-PLAT['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-PLAT['DATABASE_PORT']}=1433, ${iMC-PLAT['DATABASE_TYPE']}=SQLServer, ${iMC-PLAT['DATABASE_USER_NAME']}=imc_config, ${iMC-PLAT['DEPLOY_IP']}=127.0.0.1, ${iMC-PLAT['INNER_VERSION']}=V700R001B06D015, ${iMC-PLAT['INSTANCE_NAME']}=null, ${iMC-PLAT['JDBC_INSTANCE_NAME']}=, ${iMC-PLAT['VERSION']}=7.3-E0504, ${iMC-REPORT['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-REPORT['DATABASE_ADDRESS|1']}=127.0.0.1, ${iMC-REPORT['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-REPORT['DATABASE_INSTANCE|1']}=127.0.0.1, ${iMC-REPORT['DATABASE_NAME']}=reportplat_db, ${iMC-REPORT['DATABASE_NAME|1']}=report_db, ${iMC-REPORT['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-REPORT['DATABASE_PASSWORD|1']}={PROTECTED}, ${iMC-REPORT['DATABASE_TYPE']}=SQLServer, ${iMC-REPORT['DATABASE_TYPE|1']}=SQLServer, ${iMC-REPORT['DATABASE_USER_NAME']}=reportplat, ${iMC-REPORT['DATABASE_USER_NAME|1']}=report, ${iMC-REPORT['DEPLOY_IP']}=127.0.0.1, ${iMC-REPORT['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-REPORT['INSTANCE_NAME']}=null, ${iMC-REPORT['INSTANCE_NAME|1']}=null, ${iMC-REPORT['JDBC_INSTANCE_NAME']}=, ${iMC-REPORT['JDBC_INSTANCE_NAME|1']}=, ${iMC-REPORT['REPORT_ENGINE_TYPE']}=JRC, ${iMC-REPORT['VERSION']}=7.2-E0403P10, ${iMC-SCC['DEPLOY_IP']}=127.0.0.1, ${iMC-SCC['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-SCC['VERSION']}=7.2-E0403P10, ${iMC-SEPLAT['DEPLOY_IP']}=127.0.0.1, ${iMC-SEPLAT['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-SEPLAT['VERSION']}=7.2-E0403P10, ${iMC-SYSLOG['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-SYSLOG['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-SYSLOG['DATABASE_NAME']}=syslog_db, ${iMC-SYSLOG['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-SYSLOG['DATABASE_PORT']}=1433, ${iMC-SYSLOG['DATABASE_TYPE']}=SQLServer, ${iMC-SYSLOG['DATABASE_USER_NAME']}=imc_syslog, ${iMC-SYSLOG['DEPLOY_IP']}=127.0.0.1, ${iMC-SYSLOG['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-SYSLOG['INSTANCE_NAME']}=null, ${iMC-SYSLOG['JDBC_INSTANCE_NAME']}=, ${iMC-SYSLOG['VERSION']}=7.2-E0403P10, ${iMC-VLAN['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-VLAN['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-VLAN['DATABASE_NAME']}=vlanm_db, ${iMC-VLAN['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-VLAN['DATABASE_PORT']}=1433, ${iMC-VLAN['DATABASE_TYPE']}=SQLServer, ${iMC-VLAN['DATABASE_USER_NAME']}=vlan, ${iMC-VLAN['DEPLOY_IP']}=127.0.0.1, ${iMC-VLAN['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-VLAN['INSTANCE_NAME']}=null, ${iMC-VLAN['JDBC_INSTANCE_NAME']}=, ${iMC-VLAN['SERVER_TYPE']}=Master, ${iMC-VLAN['VERSION']}=7.2-E0403P10, ${iMC-VNM['DATABASE_ADDRESS']}=127.0.0.1, ${iMC-VNM['DATABASE_INSTANCE']}=127.0.0.1, ${iMC-VNM['DATABASE_NAME']}=vnm_db, ${iMC-VNM['DATABASE_PASSWORD']}={PROTECTED}, ${iMC-VNM['DATABASE_PORT']}=1433, ${iMC-VNM['DATABASE_TYPE']}=SQLServer, ${iMC-VNM['DATABASE_USER_NAME']}=imc_vnm, ${iMC-VNM['DEPLOY_IP']}=127.0.0.1, ${iMC-VNM['INNER_VERSION']}=V700R001B06D008SP14, ${iMC-VNM['INSTANCE_NAME']}=null, ${iMC-VNM['JDBC_INSTANCE_NAME']}=, ${iMC-VNM['VERSION']}=7.2-E0403P10}
    2017-02-01 13:21:14 [INFO ] [SwingWorker-pool-2-thread-2] [com.h3c.imc.deploy.dma.IPConfigFileManager::a(168)] Start loading server-addr.xml configuration file
    2017-02-01 13:21:14 [INFO ] [SwingWorker-pool-2-thread-2] [com.h3c.imc.deploy.dma.IPConfigFileManager::a(232)] Load server-addr.xml configuration file succeeded
    2017-02-01 13:21:14 [INFO ] [SwingWorker-pool-2-thread-2] [com.h3c.imc.deploy.dma.IPConfigFileManager::saveAllConfigs(353)] Save server address config OK
    2017-02-01 13:22:17 [ERROR] [SwingWorker-pool-2-thread-2] [com.h3c.imc.deploy.dma.SlaveUpdateWorker::doWork(228)] Master tasks execute failed, please see dmslog.txt on master server.

    ========================

    I tried to reboot the server but I still got the same issue when I try to perform the upgrade... Does anyone can help me to solve this issue ?

    Thanks in advance for your help

    Regards,

    Matt



  • 2.  RE: IMC 7.3 - Upgrade error

    Posted Feb 01, 2017 11:47 AM

    Is that the dmslog.txt file? If not, can you get a copy of that?



  • 3.  RE: IMC 7.3 - Upgrade error

    Posted Feb 02, 2017 03:37 AM

    Hi !

    Thanks for your reply.

    As requested, you can find below a link to download the complete dmslog.txt.

    https://www.transfernow.net/15ew71m1j49x

    Thanks in advance

    Best regards,

    Matt



  • 4.  RE: IMC 7.3 - Upgrade error

    Posted Feb 02, 2017 07:04 AM

    Hi,

    thanks for your answer. As requested, you can find below a link to download the complete log file.

    https://www.transfernow.net/11eux7l2r0aq

    Thanks in advance

    Best regards,

    M@tt



  • 5.  RE: IMC 7.3 - Upgrade error

    Posted Feb 02, 2017 11:14 AM

    Did you look at the logfile?

    Look at the ERROR line near the end. That indicates either a corrupted download, or possibly insufficient disk space when unzipping some of the content. I would start by checking md5sums



  • 6.  RE: IMC 7.3 - Upgrade error

    Posted Feb 03, 2017 01:43 AM

    Yes of course I also saw this unzip error in the logs.. I tried both to download the complete upgrade once and also to add around 36GB of free space instead of the 16GB who were currently available but it didn't changed anything.. As it's a VM I'll restore a complete backup and try the upgrade again... I'll let you know if that works.

    Thanks for your help

    M@tt



  • 7.  RE: IMC 7.3 - Upgrade error

    Posted Feb 03, 2017 07:26 AM

    Ok so it was definitely my mistake.. sorry... I restored the server completely and tried to upgrade it again with a new downloaded file and this time it worked perfectly... I think the problem was because when I first tried, I just upgraded the IMC without rebooting the server first... So I would definitely recommend to reboot the server prior the upgrade to avoid any issue..

    Thanks for your help @LindsayHill

    Best regards

    M@tt



  • 8.  RE: IMC 7.3 - Upgrade error

    Posted Feb 03, 2017 02:06 PM

    Good to hear it's working! I've heard of some problems in the past that required a reboot - something to do with trying to delete the JRE while it was in use. I think it had a different error message though.

    Hopefully the new version is working well