Network Management

 View Only
  • 1.  [IMC v7.1p13] Adding check task fails

    Posted Jul 29, 2015 07:49 AM

    Hi everyone, I'm currently testing the trial of the IMC v7.1p13. When I add an custom check-task and save my configuration (task-name, policy, devices), the process fails with the following error-message:

     

    org.apache.myfaces.view.facelets.el.ContextAwareELException: javax.el.ELException: org.springframework.dao.InvalidDataAccessResourceUsageException: could not insert: [com.h3c.imc.icc.regex.entity.IccRuleHistoryEntity]; SQL [insert into tbl_check_rule_history (check_content, check_content_end, check_content_start, check_type, command, config_command, create_time, creator, exec_method, file_path, recover_command, rule_des, ruleid, rule_name, rule_severity, rule_standard, support_firm, task_id, type) values (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)]; nested exception is org.hibernate.exception.SQLGrammarException: could not insert: [com.h3c.imc.icc.regex.entity.IccRuleHistoryEntity]
    at org.apache.myfaces.view.facelets.el.ContextAwareTagMethodExpression.invoke(ContextAwareTagMethodExpression.java:108)
    at org.apache.myfaces.application.ActionListenerImpl.processAction(ActionListenerImpl.java:68)
    ...
    Caused by: javax.el.ELException: org.springframework.dao.InvalidDataAccessResourceUsageException: could not insert: [com.h3c.imc.icc.regex.entity.IccRuleHistoryEntity]; SQL [insert into tbl_check_rule_history (check_content, check_content_end, check_content_start, check_type, command, config_command, create_time, creator, exec_method, file_path, recover_command, rule_des, ruleid, rule_name, rule_severity, rule_standard, support_firm, task_id, type) values (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)]; nested exception is org.hibernate.exception.SQLGrammarException: could not insert: [com.h3c.imc.icc.regex.entity.IccRuleHistoryEntity]
    at org.apache.el.parser.AstValue.invoke(AstValue.java:291)
    at org.apache.el.MethodExpressionImpl.invoke(MethodExpressionImpl.java:273)
    at org.apache.myfaces.view.facelets.el.ContextAwareTagMethodExpression.invoke(ContextAwareTagMethodExpression.java:96)
    ... 48 more
    Caused by: org.springframework.dao.InvalidDataAccessResourceUsageException: could not insert: [com.h3c.imc.icc.regex.entity.IccRuleHistoryEntity]; SQL [insert into tbl_check_rule_history (check_content, check_content_end, check_content_start, check_type, command, config_command, create_time, creator, exec_method, file_path, recover_command, rule_des, ruleid, rule_name, rule_severity, rule_standard, support_firm, task_id, type) values (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)]; nested exception is org.hibernate.exception.SQLGrammarException: could not insert: [com.h3c.imc.icc.regex.entity.IccRuleHistoryEntity]
    at org.springframework.orm.hibernate3.SessionFactoryUtils.convertHibernateAccessException(SessionFactoryUtils.java:635)
    at org.springframework.orm.hibernate3.HibernateAccessor.convertHibernateAccessException(HibernateAccessor.java:412)
    ...
    ... 50 more
    Caused by: org.hibernate.exception.SQLGrammarException: could not insert: [com.h3c.imc.icc.regex.entity.IccRuleHistoryEntity]
    at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:92)
    at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:66)
    ...
    ... 61 more
    Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: Bei der Konvertierung eines nvarchar-Datentyps in einen datetime-Datentyp liegt der Wert außerhalb des gültigen Bereichs.
    at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:216)
    at com.microsoft.sqlserver.jdbc.SQLServerStatement.getNextResult(SQLServerStatement.java:1515)
    at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement.doExecutePreparedStatement(SQLServerPreparedStatement.java:404)
    ...
    ... 79 more

    Has anyone an idea what the problem might be?

     

    Kind regards Tobias

     

    /edit: updated for readability



  • 2.  RE: [IMC v7.1p13] Adding check task fails

    Posted Jul 30, 2015 08:27 PM

    Works OK for me but I'm running mySQL backend



  • 3.  RE: [IMC v7.1p13] Adding check task fails

    Posted Jul 31, 2015 01:21 AM

    I wonder if there's something funny going on with a language/character conversion?



  • 4.  RE: [IMC v7.1p13] Adding check task fails

    Posted Jul 31, 2015 01:42 AM

    I forgot to mention:

    - System: Windows Server 2012R2

    - DB: MSSQL-Server 2008SP3

     

    The problem only occurs when I use one of my custom made Policies with custum rules like this one:

    Basic Information
    Name             check syslog
    Type             User Defined
    Severity Level   Major
    Check Target     Latest backup running configuration
    Vendor           All
    Check Type       Device
    Description      -
    
    Rule Type        Basic
    Match Mode       Strict Match
    Match Patterns   logging 10.x.y.z control-descr "syslog-target"